Website, Control Panel, SMP and authentication flow being inaccessible

Incident Report for NordLayer

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:00 EET

Monitoring

Cloudflare has announced that all services should now be recovering.
Posted Nov 18, 2025 - 16:52 EET

Identified

All issues have been identified to be related to the global Cloudflare outage
Posted Nov 18, 2025 - 13:42 EET

Investigating

We are seeing failing requests for attempts to reach our website, Control Panel, Partner Portal (SMP) and when trying to log into either Control Panel, SMP or NordLayer Application/Browser Extension.
Posted Nov 18, 2025 - 13:39 EET
This incident affected: NordLayer Website, NordLayer Control Panel, NordLayer Service Management Platform (SMP), and NordLayer Applications.